Amp Meter not working

Discussion on keeping your aircraft airworthy and legal and/or any technical topics.


Post Reply
User avatar
Mauleflyer
Posts: 47
Joined: Thu Mar 06, 2008 7:02 pm
Location: Haddonfield, NJ
Contact:

Amp Meter not working

Post by Mauleflyer »

The amp meter appears to be not working in my Mx-7-180. Needle is in the middle, can’t get the needle to move one way or the other regarding of what I turn on or off including starting. I have a USB charger in the cigarette lighter that shows 13.5-13.6v during flight which is normal so I don’t think there is a charging issue. Has anyone seen this? Is it possible to replace the amp meter or do you have to replace the entire instrument bar?

User avatar
andy
Site Admin
Posts: 1228
Joined: Mon Aug 06, 2007 2:05 pm
Location: Lake James, NC, USA
Contact:

Re: Amp Meter not working

Post by andy »

Other than the ammeter, which is part of the instrument cluster module, the shunt might be bad. I haven't actually looked at one on a Maule but they're usually ceramic wirewound resistors with a very low resistance. If one of them goes bad, it's usually a bad or loose terminal connection or the ceramic and wire break somewhere due to thermal expansion and contraction. You might want to make sure all the terminal connections are secure before you buy anything. Broken or loose ring lug terminals attached to the shunt could also be a problem.

The meter might be bad but that would be less likely than a loose terminal.

Someone who has actually looked at one of these is welcome to chime in.
Andy
1986 MX7-180

User avatar
Mauleflyer
Posts: 47
Joined: Thu Mar 06, 2008 7:02 pm
Location: Haddonfield, NJ
Contact:

Re: Amp Meter not working

Post by Mauleflyer »

Thanks, I think you are correct about the shunt or wire. I am having it looked at, will let you know.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests